Performance issue impacting Pod 4 customers
Incident Report for Titan PMR
Resolved
Emergency maintenance on Pod 4 has been successful and all services are operating normally.
Posted Jul 12, 2023 - 19:35 UTC
Monitoring
We have seen recovery from the earlier incident and systems are operating normally. We will remain in a period of close monitoring for the next 12 hours, and emergency maintenance will take place later this evening.
Posted Jul 12, 2023 - 15:47 UTC
Identified
We have identified this issue and have seen some improvement since 16:25. We are continuing to work on a resolution to fix the cause. This may require emergency maintenance this evening and separate communications will be issued with regard to this.

In the meantime please continue to use Titan as the performance fluctuation is likely to be temporary. Rest assured this is a high priority incident that we are addressing.

Further updates will follow shortly
Posted Jul 12, 2023 - 15:35 UTC
Investigating
We are currently investigating an temporary performance issue impacting customers on Pod 4. We are working to resolve this issue and will provide an update shortly.
Posted Jul 12, 2023 - 15:26 UTC
This incident affected: Titan core API platform.