Titan helpdesk voice service unavailable

Incident Report for Titan PMR

Resolved

Our third party provider has resolved the issue relating to inbound and outbound voice comms with our support team.

Telephone lines are fully operational again to supplement the non-voice methods of contact that have been operational throughout. A reminder of how to contact our support team is here https://www.titanpmr.com/support
Posted Oct 20, 2025 - 12:21 UTC

Investigating

We are currently impacted by a wide ranging outage across multiple service providers meaning we are unable to currently receive or make voice calls to/from our support team.

You can contact our support team directly via any one of the methods listed here https://www.titanpmr.com/support (scroll down to view the options), and the team are on hand to assist with any queries as normal.

Titan is unaffected by this incident.

We will provide an update when we have more info
Posted Oct 20, 2025 - 08:28 UTC
This incident affected: Titan Helpdesk.