Performance issue impacting Pod 3 customers
Incident Report for Titan PMR
Resolved
After close monitoring this Incident is now resolved and all services are operating normally.
Posted Aug 09, 2023 - 15:15 UTC
Monitoring
We have seen recovery from the earlier incident and systems are operating normally. We will remain in a period of close monitoring
Posted Aug 09, 2023 - 12:06 UTC
Identified
We have identified this issue and have seen some improvement since.

In the meantime please continue to use Titan as the performance fluctuation is likely to be temporary. Rest assured this is a high priority incident that we are addressing.

Further updates will follow shortly
Posted Aug 09, 2023 - 12:00 UTC
Investigating
We are currently investigating an temporary performance issue impacting customers on Pod 3. We are working to resolve this issue and will provide an update shortly.
Posted Aug 09, 2023 - 11:57 UTC
This incident affected: Titan core API platform.