Titan helpdesk voice calls
Incident Report for Titan PMR
Resolved
This incident has now been resolved.

Our apologies for any inconvenience this may have caused.
Posted Sep 08, 2023 - 11:47 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 31, 2023 - 15:59 UTC
Identified
We are currently experiencing an issue where inbound telephone calls are not always being routed to Titan helpdesk agents, despite agents being available to take calls. This is being investigated by the third party software provider we use for voice calls but in the meantime if you call you might not receive an answer.

As a workaround until this issue is resolved, if you require support we recommend you either use email support@titanpmr.com, whatsapp +441173254755 or in-app chat via the Support icon on the left hand menu bar in Titan.

We will provide an update when inbound voice calls are fully operational again. Apologies for any inconvenience this may cause.
Posted Aug 31, 2023 - 13:41 UTC
This incident affected: Titan Helpdesk.