EPS prescription downloads
Incident Report for Titan PMR
Resolved
After investigating thoroughly and with an abundance of caution, we are satisfied that there was no issue earlier. All systems remained fully operational throughout.
Posted Jul 24, 2024 - 18:03 UTC
Monitoring
All Titan systems are operating normally after detailed checks.

We are working with the NHS team to double check everything is OK - at present Titan does appear to be working as expected. We will provide an update when we've had full confirmation from the NHS.
Posted Jul 24, 2024 - 15:22 UTC
Identified
We are in touch with the NHS EPS team to investigate further and will provide an update shortly
Posted Jul 24, 2024 - 15:03 UTC
Investigating
We are investigating reports from a small number of sites that EPS prescription downloads are not working. We are investigating currently and will provide an update shortly.
Posted Jul 24, 2024 - 14:42 UTC
This incident affected: Titan access to NHS.