Incident affecting peripherals

Incident Report for Titan PMR

Resolved

This incident has been resolved.
Posted Oct 17, 2025 - 08:12 UTC

Update

This is the solution to the peripherals issue if you experience it following a windows update to a PC

Please follow these steps:

1. Open TITAN
2. Settings cog at the bottom left
3. System Info
4. Click "Run Loopbackexempt"
5. Wait for the black "CMD" window to open and close
6. Reboot the PC

(In a very small number of cases, a second reboot is required for the fix to apply)
Posted Oct 17, 2025 - 08:04 UTC

Update

We have found a way to solve the issue without needing to uninstall or pause windows updates. This has worked in the majority of cases reported this morning.

Please follow these steps:

1. Open TITAN
2. Settings cog at the bottom left
3. System Info
4. Click "Run Loopbackexempt"
5. Wait for the black "CMD" window to open and close
6. Reboot the PC

(In a very small number of cases, a second reboot is required for the fix to apply)

We are continuing to investigate this but our current recommendation if you experience this issue is to try this option.
Posted Oct 16, 2025 - 09:02 UTC

Update

We are continuing to investigate the root cause of the Windows Update affecting peripherals on some PCs. This work will continue today however in the meantime we advise any customers affected to follow the steps provided to remove the update(s) and pause future updates for a short period.

To help with this activity, we have built a simple tool that you can run on any PC. It will search for the two updates, remove them, and offer you the option to pause updates.

You can download the tool here:

[PLEASE SEE LATEST UPDATE FOR APPROVED SOLUTION]

Download the file, run it, say yes to the prompts and at the end restart your PC when prompted.

We will be in touch with further updates later today.
Posted Oct 16, 2025 - 06:57 UTC

Monitoring

We have since Identified a workaround:

1. Go to Windows settings
2. Go to Windows updates
3. Go to update history
4. Scroll down to uninstall updates
5. Then, uninstall KB5066835
6. After this, if KB5065789 is showing as installed, then uninstall this too.
7. Restart PC.

Titan should then be working as expected, if you continue to have any remaining issues after completing these steps, please contact our helpdesk.

We recommend pausing your Windows updates for 2 weeks. We will continue to investigate this to ascertain the root cause and subsequent availability of a fix from Microsoft.

Thank you for your patience whilst we investigated this incident caused by a Windows update.
Posted Oct 15, 2025 - 10:46 UTC

Identified

We are investigating an incident affecting PCs where they are unable to use peripherals with Titan.

This appears to relate to customers who have installed a windows update overnight. If no updates were installed then peripherals are working as normal.

We are working to identify the specific update causing this and will provide further information shortly.
Posted Oct 15, 2025 - 08:18 UTC
This incident affected: Titan core API platform.