After a period of monitoring all services remain operational. EPS prescription downloads have resumed.
Posted Nov 20, 2025 - 06:39 UTC
Identified
Services restored fully at approximately 1am with all HSCN services now operational.
Prescription nominated download requests remain disabled during an extended period of monitoring, and will be resumed by 7am.
Posted Nov 20, 2025 - 04:34 UTC
Investigating
We are currently investigating an issue relating to the consistency of our HSCN connectivity. We are observing HSCN access intermittently switch from being fully operational to offline, and then back. Normal Titan access is fully operational.
Engineers are investigating the issue.
We have disabled nominated downloads of new EPS prescriptions until the morning to ensure that there are no issues with prescription availability.
We will provide a further update in the coming hours.