Titan helpdesk

Incident Report for Titan PMR

Resolved

After a short period of monitoring all helpdesk services remain operational.
Posted Dec 05, 2025 - 10:16 UTC

Update

All helpdesk services are restored and you can contact us if needed via the usual channels.

We will continue monitoring.
Posted Dec 05, 2025 - 09:22 UTC

Monitoring

This appears to be a CloudFlare issue affecting multiple different services. We are seeing services restore now and we are monitoring the progress.
Posted Dec 05, 2025 - 09:19 UTC

Investigating

The third party software tool we use for service management is currently experiencing an outage, as a result our service desk is temporarily unavailable. We are speaking to them about a resolution and hope to have all support channels operational as soon as possible.

We will provide an update when we have more information.

NB: This does not affect the operation of Titan, only our helpdesk services.
Posted Dec 05, 2025 - 08:59 UTC
This incident affected: Titan Helpdesk.